1010 Radix (25 分)

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tagis 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

分析:先将n1转化为10进制,然后通过find确定下界,上界不可能比n2小 ,当上界为n2+1时,在我的代码中有些会和下界重合,所以我设为n2+2,之后二分radix即值mid,得到对应n2的10进制,比较

转换进制时数值可能比较大,所以用long long,有些即使是long long 也会溢出,这部分舍弃,即当转化为十进制后小于0的舍弃,上界改变

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 100001;
map<char,int> Map;
ll find(string n){//答案里的某一位数比n2还小是不可能,找到其中最大的数,就是下界 
	char mx=n[0];
	for(int i=0;i<n.length();i++){
		if(n[i]>mx){
			mx=n[i];
		}
	}
	return Map[mx]+1;
}
int main(){//特例:0 0 1 100         12 c 1 10   
	char ch='a';
	for(int i=0;i<26;i++){
		Map.insert(pair<char,int>(ch,i+10));
		ch++;
	}
	ch='0';
	for(int i=0;i<=9;i++){
		Map.insert(pair<char,int>(ch,i));
		ch++;	
	}
	string n1,n2;
	ll tag,radix;
	cin>>n1>>n2>>tag>>radix;
	if(n1=="0" && n2=="0"){
		cout<<1;
		return 0;
	} 
	if(tag==2){
		string t=n1;
		n1=n2;
		n2=t;
	}
	ll decimal=0,k=0;
	for(int i=n1.length()-1;i>=0;i--){
		decimal+=Map[n1[i]]*pow(radix,k++);
	}
	ll decimal1=0,sign=0,ans=0,left=find(n2),right=decimal+2;
	while(left<right){
		ll mid=left+(right-left)/2;
		string temp=n2;
		k=0;
		decimal1=0;
		for(int i=temp.length()-1;i>=0;i--){ 
			decimal1+=Map[temp[i]]*pow(mid,k++);
		}
		if(decimal==decimal1){
			sign=1;
			ans=mid;
			right=mid;
		}
		else if(decimal1>decimal || decimal1<0){
			right=mid;
		}
		else{
			left=mid+1;
		}
	}
	if(!ans){
		cout<<"Impossible";
	}
	else{
		cout<<ans;
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值