A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes
if N is a reversible prime with radix D, or No
if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
#include<vector>
#include<iostream>
#include <algorithm>
#include <math.h>
using namespace std;
bool isPrime(int sum){
if(sum<=1)
return false;
for(int i=2;i<=sqrt(sum*1.0);i++){
if(sum%i == 0)
return false;
}
return true;
}
int main(){
int input,temp,radix,sum=0;
cin>>input;
while (input>=0){
cin>>radix;
temp=input;
vector<int>a;
while (temp){
a.push_back(temp % radix);
temp/=radix;
}
for(int i=0;i<a.size();i++)
sum=sum * radix + a[i];
if(isPrime(input)&&isPrime(sum))
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
sum=0;
cin>>input;
}
return 0;
}