How Many Fibs?(高精度+打表+字符比较)

How Many Fibs?(高精度+打表+字符比较)

description:

Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.

Sample Input

10 100
1234567890 9876543210
0 0

Sample Output

5
4

题解:
本题为统计一段区间内斐波那契数字的个数,思路是先打表存斐波那契数,把输入的两个字符串倒序存入整数数组中,通过比较来判断这个数是否在区间内。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;

int f[600][110],a1[110],b1[110];
int main()
{
    string a,b;
    while(cin>>a>>b)
    {
        memset(f,0,sizeof(f));
        memset(a1,0,sizeof(a1));
        memset(b1,0,sizeof(b1));        //初始化!!!!!!!;
        if(a=="0"&&b=="0")
            break;
        int lena=a.length(),lenb=b.length();
        for(int i=lena-1,j=0; i>=0; i--,j++)  //把a,b倒序存入整数数组中;
            a1[j]=a[i]-'0';
        for(int i=lenb-1,j=0; i>=0; i--,j++)
            b1[j]=b[i]-'0';
        f[1][0]=1;               //注意f1=1,f2=2;
        f[2][0]=2;
        for(int i=3; i<600; i++)    //大斐波数打表存入;
        {
            for(int j=0; j<110; j++)
            {
                f[i][j]=f[i-1][j]+f[i-2][j];
            }
            int m=0;
            for(int j=0; j<110; j++)
            {
                int sum=f[i][j]+m;
                m=sum/10;
                f[i][j]=sum%10;
            }
        }
        int ans=0;     //用来保存结果;
        for(int i=1; i<600; i++)
        {
            int flag1=0;
            for(int j=109; j>=0; j--)
            {
                if((f[i][j]>a1[j])||(f[i][j]==a1[j]&&j==0))   //通过字符比较,判断f[i][j]
                {                                             //是否>=a;
                    flag1=1;
                    break;
                }
                else if(f[i][j]==a1[j])
                    continue;
                else if(f[i][j]<a1[j])
                    break;
            }
            int flag2=0;
            for(int j=109; j>=0; j--)                //通过字符比较,判断f[i][j]是否<=b;
            {
                if((f[i][j]<b1[j])||(f[i][j]==b1[j]&&j==0))
                {
                    flag2=1;
                    break;
                }
                else if(f[i][j]==b1[j])
                    continue;
                else if(f[i][j]>b1[j])
                    break;
            }
            if(flag1==1&&flag2==1)         //统计满足条件的值;
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值