Jungle Roads
题目描述:
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30
题意:
有n个村庄,给定村庄之间已有的一些道路,从中选取部分道路使村庄之间均能相互到达并使维护费用最低。
**题解:**明显的最小生成树问题,注意一下输入细节就好,这里我用的Kruskal算法,每个村的编号是以字母给出的,可以转化成数字编号的形式。
AC代码:
#include <iostream>
#include <algorithm>
#include <math.h>
#include <cstdio>
#include <cmath>
#include <stdlib.h>
using namespace std;
int n,id,pre[30]; //pre[]表示父节点集合,id用来记录边数;
struct node //用结构体来描述边;
{
int from,to,w;
} e[100];
bool cmp(node a,node b) //按权值排序;
{
return a.w<b.w;
}
int Find(int x) //找根结点(并查集)
{
if(x==pre[x])
return x;
else
return pre[x]=Find(pre[x]);
}
int Kruskal()
{
for(int i=1; i<=n; i++) //初始化pre数组;
pre[i]=i;
sort(e,e+id,cmp); //按权值由小到大排序;
int sum=0,cnt=0; //sum表示最小生成树各条边的总权值;
for(int i=0; i<id; i++)
{
int u=e[i].from,v=e[i].to,w=e[i].w; //取出每条边的端点和权值;
int fu=Find(u),fv=Find(v); //找根节点;
if(fu==fv)
continue; //已在最短路径中,不加入;
else
{
sum+=w;
cnt++;
pre[fu]=fv; //连接两棵树(并查集);
}
}
return sum;
}
int main()
{
while(~scanf("%d",&n),n!=0)
{
id=0; //多组输入,id一定要置零;
for(int i=1; i<=n-1; i++)
{
char u;
int k;
cin>>u>>k;
for(int i=1; i<=k; i++)
{
char v;
int cost;
cin>>v>>cost;
e[id++]= {u-'A'+1,v-'A'+1,cost}; //把起点和终点分别转化成数字的形式;
}
}
int ans=Kruskal();
cout<<ans<<endl;
}
return 0;
}