【PAT】1025. PAT Ranking (25)

1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
分析:排序题;一个队列排总体,分组输入过程中用一个队列记录该组排序并记录在结构体中;
细节:非降序排序,处理相等排序的方法;
#include <iostream>
#include <queue>
#include <string>
using namespace std;

class node
{
	public:
		string index;
		int grade;
		int rank;
		int group;
		node(string str, int x, int r, int g){
			index=str;
			grade=x;
			rank=r;
			group=g;
		}
		friend bool operator < (const node &a, const node &b){
			return a.grade<b.grade || (a.grade==b.grade&&a.index>b.index);
		}
};

int main()
{
//	freopen("test.txt","r",stdin);
	priority_queue<node> q1,q;
	int N;
	cin>>N;
	for (int i=0;i<N;++i){
		int K;
		cin>>K;
		for (int j=0;j<K;++j){
			string str;
			int x;
			cin>>str>>x;
			node temp(str,x,0,i+1);
			q1.push(temp);
		}
		int rank=1;
		int flag=1;
		while(!q1.empty()){
			++flag;
			node temp=q1.top();
			temp.rank=rank;
			q.push(temp);
			q1.pop();
			if (!q1.empty() && temp.grade!=q1.top().grade) rank=flag;
		}
	}
	int rank=1;
	int flag=1;
	cout<<q.size()<<endl;
	while (!q.empty()){
		++flag;
		node temp=q.top();
		cout<<temp.index<<' '
			<<rank<<' '
			<<temp.group<<' '
			<<temp.rank<<endl;
		q.pop();
		if (!q.empty() && temp.grade!=q.top().grade) rank=flag;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值