【PAT】1116 Come on! Let's C (20)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

 

#include <iostream>

using  namespace std;

int a[10001];

int isP(int x){
    for (int i=2;i<x/2;++i){
        if (x%i==0) return 0;
    }
    return 1;
}

int main(){
//    freopen("test.txt", "r", stdin);
    int n,m;
    int x;
    cin>>n;
    for (int i=1;i<=n;++i) {
        cin>>x;
        a[x] = i;
    }
    cin>>m;
    for (int i=0;i<m;++i){
        cin>>x;
        if (a[x]>0) {
            if (a[x]==1) {
                printf("%04d: %s\n", x, "Mystery Award");
            } else {
                if (isP(a[x])) printf("%04d: %s\n", x, "Minion");
                else printf("%04d: %s\n", x, "Chocolate");
            }
            a[x]=-1;
        } else if (a[x]==0) printf("%04d: %s\n", x, "Are you kidding?");
        else printf("%04d: %s\n", x, "Checked");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值