【题解】【PAT甲】1143 Lowest Common Ancestor (30 分)(树)(BST)(最近公共祖先)

27 篇文章 0 订阅

题目链接

PTA | 程序设计类实验辅助教学平台

题目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

结尾无空行

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

结尾无空行

题目大意

 给一个BST树的先序序列,再给出两个节点,如果两个节点不存在输出不存在,如果存在求两个节点的共同祖先,如果一个节点是另一个节点的祖先,输出特殊的语句

解题思路

 一开始想着链表建树然后遍历找找这个节点在不在树上,然后用vector存储走过的路径,通过走过的路径判断,应该没有比这个还暴力的解法了吧?三个测试点超时哈哈哈哈哈,硬撕了18分

#include<bits/stdc++.h>
using namespace std;
struct Node{
	int val;
	Node* left;
	Node* right;
};
Node* insert(Node* root,int val){
	if(root==NULL){
		root=new Node();
		root->left=NULL;
		root->right=NULL;
		root->val=val;
	}
	else{
		if(val>=root->val){
			root->right=insert(root->right,val);
		}
		else{
			root->left=insert(root->left,val);
		}
	}
	return root;
}
vector<int> va;
vector<int> vb;
vector<int> v;
bool find(Node* root,int val){
	if(root==NULL)	return false;
	v.push_back(root->val);
	if(root->val==val)	return true;
	if(val>root->val)	return find(root->right,val);
	else	return find(root->left,val);
}
int main(){
	int m,n;
	cin>>m>>n;
	Node* root=NULL;
	for(int i=0;i<n;i++){
		int data;
		scanf("%d",&data);
		root=insert(root,data);
	}
	while(m--){
		int a,b;
		va.clear();
		vb.clear();
		v.clear();
		scanf("%d %d",&a,&b);
		bool fa=find(root,a);
		if(fa)	va=v;
		v.clear();
		bool fb=find(root,b);
		if(fb)	vb=v;
		bool f=false;
		if(fa&&fb){
			int i;
			for(i=0;i<va.size()&&i<vb.size();i++){
				if(va[i]!=vb[i]){
					printf("LCA of %d and %d is %d.\n",a,b,va[i-1]);
					f=true;
					break;
				} 
			}
			if(!f){
				if(i==va.size())	printf("%d is an ancestor of %d.\n",a,b);
				else if(i==vb.size())	 printf("%d is an ancestor of %d.\n",b,a);
			}
			
		}
		else if(!fa&&fb){
			printf("ERROR: %d is not found.\n",a);
		}
		else if(fa&&!fb){
			printf("ERROR: %d is not found.\n",b);
		}
		else{
			printf("ERROR: %d and %d are not found.\n",a,b);
		}
	}
} 

 然后参考了一下柳婼的题解PAT 1143. Lowest Common Ancestor (30) – 甲级_柳婼 の blog-CSDN博客

发现可以用map存储节点是否出现,对于BST树,比他小的值一定在它的左子树上,大于等于他的值一定在它的右子树上,所以只需要遍历先序序列的每一个节点的值,然后判断给出的uv

如果在v[i]的两边,说明v[i]就是他们的祖先节点

如果有一个等于v[i],说明一个是另一个的父节点

题解

#include<bits/stdc++.h>
using namespace std;
int main(){
	int m,n;
	cin>>m>>n;
	vector<int> v(n);
	map<int,int> ma;
	for(int i=0;i<n;i++){
		cin>>v[i];
		ma[v[i]]++;
	}
	for(int i=0;i<m;i++){
		int a,b;
		cin>>a>>b;
		if(ma[a]==0&&ma[b]==0){
			printf("ERROR: %d and %d are not found.\n",a,b);
		}
		else if(ma[a]!=0&&ma[b]!=0){
			for(int i=0;i<n;i++){
				if(v[i]==a){
					printf("%d is an ancestor of %d.\n",a,b);
					break;
				}
				else if(v[i]==b){
					printf("%d is an ancestor of %d.\n",b,a);
					break;
				}
				else if(v[i]>a&&v[i]<b||v[i]<a&&v[i]>b){
					printf("LCA of %d and %d is %d.\n",a,b,v[i]);
					break;
				}
			}
		}else{
			printf("ERROR: %d is not found.\n",ma[a]?b:a);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值