[PTA刷题]Pop Sequence

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MMis 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN(the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO


#include <iostream>

using namespace std;


typedef struct SNode *Stack;
struct SNode{
    int data;
    Stack next;
};


Stack create(){
    Stack S;
    S=(Stack)malloc(sizeof(struct SNode));
    S->next=NULL;
    return S;
}

int IsEmpty(Stack S){
    return (S->next==NULL);
}


void Push(int item, Stack S){
    Stack tempCell;
    tempCell = (Stack)malloc(sizeof(struct SNode));
    tempCell->data = item;
    tempCell->next=S->next;
    S->next=tempCell;
}

int Pop(Stack S){
    Stack firstCell;
    int TopElm;
    if(IsEmpty(S)){
        return NULL;
    }else{
        firstCell=S->next;
        TopElm=firstCell->data;
        S->next=firstCell->next;
        free(firstCell);
        return TopElm;
    }
}


int decide(int capacity, int length)
{
    int dcapacity=capacity;
    int dlength=length;
    int thePopElm,currentCap=0,top1=0,popout;
    int flag=1;
    
    Stack myS=create();
    
    while (dlength--) {
 
        cin>>thePopElm;
        if(thePopElm>top1){
            for(int i=top1; i<thePopElm;i++){
                Push(i+1, myS);
               
                currentCap++;
                if(currentCap>dcapacity) flag=0; //这里不可以直接return 0;
            }
            top1=thePopElm;//top1纪录的是到目前为止读入的最大的那个数。也就是push进stack过的最大的那个。在pop出一个数之前必须先push它前面的那些数。
        }
        
        popout=Pop(myS);
        currentCap--;
        if(popout!=thePopElm) flag=0; //这里不可以直接return 0;
        
    }
    
    if(flag) return 1;
    else return 0;
    
}




int main()
{
    int capacity, length, count;
    cin>>capacity>>length>>count;

    
    for(int j=0;j<count;j++){
        if(decide(capacity, length))
            cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    

    
    return 0;
}


一开始犯的一个错误是,提早return 0了。这样子,一行序列未完全读完,就已经返回了。会把一行数字的输入打断。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值