[PTA刷题]树List Leaves

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 1010) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1N1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5



solution:

#include <iostream>
#include <queue>

using namespace std;

#define MaxTree 10
#define Tree int
#define Null -1

struct TreeNode{
    Tree Left;
    Tree Right;
}T1[MaxTree];

int flag=0;

Tree BuildTree(TreeNode T[]);

void TraverseLeaves(Tree root);

int main(){
    Tree R1;
    R1=BuildTree(T1);
    
    TraverseLeaves(R1);
    
    return 0;
}

Tree BuildTree(TreeNode T[]){
    Tree root=Null;
    int N,check[MaxTree];
    char lc,rc;
    cin>>N;
    
    if(N>0){
        for(int i=0;i<N;i++)
            check[i]=0;
    
        for(int i=0; i<N; i++){
            cin>>lc>>rc;
            
            //left child
            if(lc!='-'){
                T[i].Left=lc-'0';
                check[T[i].Left]=1;
            }else
                T[i].Left=Null;
            
            //right child
            if(rc!='-'){
                T[i].Right=rc-'0';
                check[T[i].Right]=1;
            }else
                T[i].Right=Null;
            
        }
        //end of inputing T[]
        
        for(int i=0;i<N;i++){
            if(check[i]==0)
            {   root=i;
                break;
            }
        }
    }
    return root;
}

//level order traversal
void TraverseLeaves(Tree root)
{
    queue<int> theQ;
    Tree node;
    theQ.push(root);
    
    while(!theQ.empty()){
        node=theQ.front();
        theQ.pop();
        
        
        if(T1[node].Left==Null && T1[node].Right==Null )
        {
            if(flag==0){
                cout<<node;
                flag=1;
            }else
                cout<<' '<<node;
        }
        else{
            if(T1[node].Left!=Null)
                theQ.push(T1[node].Left);
            if(T1[node].Right!=Null)
                theQ.push(T1[node].Right);
        }
    
    }

}


思路:

考查的是对树的存储和遍历。

这里用到了和“树的同构”一题里相同的存储树的方法。

遍历树的时候要用的是层序遍历,以满足题目的“从上到下从左到右的叶子节点的输出”的要求。

学习了一下c++ stl里queue的用法。


树的层序遍历的基本思路:

void LevelOrderTraversal(BinTree BT)
{
    Queue Q;
    BinTree T;
    if(!BT) return;
    Q=CreateQueue(MaxSize);
    AddQ(Q,BT);
    while(!IsEmpty(Q)){
        T=DeleteQ(Q);
        printf("%d\n",T->Data);
        if(T->Left) AddQ(Q,T->Left);
        if(T->Right) AddQ(Q,T->Right);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值