HDU 4864

Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0 < xi < 1440),yi(0 =< yi <= 100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0 < xi < 1440),yi(0 =< yi<= 100).xi is the time we need to complete the task.yi is the level of the task.
Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
Sample Input

1 2
100 3
100 1

Sample Output

1 50004

这道题是一道贪心算法的题,主要是要先把machine和task分别按照x, y从大到小排序。还要注意这道题的总钱数可能很大,要用__int64存储。比较巧妙地用c[]存储了所有满足条件的y,这也是本题的要点。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
const int maxn = 100000 + 5;

typedef struct xy
{
    int x, y;
}xy;

int cmp(xy a, xy b)
{
    if (a.x == b.x) return a.y > b.y;
    return a.x > b.x;
}

int main()
{
    //freopen ("in.txt", "r", stdin);
    xy machine[maxn], task[maxn];
    int n, m, f;
    __int64 sum;
    while (cin >> n >> m) {
        f = 0;
        sum = 0;
        memset (machine, 0, sizeof(machine));
        memset (task, 0, sizeof(task));
        for (int i = 0; i < n; i++) {
            cin >> machine[i].x >> machine[i].y;
        }
        for (int i = 0; i < m; i++) {
            cin >> task[i].x >> task[i].y;
        }
        sort (machine, machine + n, cmp);
        sort (task, task + m, cmp);
        //cout << task[0].y << " " << task[1].y << endl;
        int c[105] = {0};
        for (int i = 0, j = 0; i < m; i++) {
            while(j < n && machine[j].x >= task[i].x) {//把x满足条件的machine的y都存起来
                c[machine[j].y]++;
                j++;
            }
            for (int k = task[i].y; k <= 100; k++) {
                if (c[k]) {//找一个满足y条件的
                    f++;
                    c[k]--;
                    sum = sum + 500 * task[i].x + 2 * task[i].y;
                    break;
                }
            }
        }
        cout << f << " " << sum << endl;
    }
    return 0;
}

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值