uva 10305(用DFS实现拓扑排序)

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
4 1 5 2 3

(这道题的原题的Sample Output是错的,我改成正确的了。我说怎么调了半天程序没调出来。哭。)

题意:给你一个n与m,n代表总共任务数,m表示要求数目。下面m行每一行的第一个数代表的任务必须在第二个数代表的任务之前做,不能有闭合环,也就是不能a->b->a。具体实现方式看代码中注释。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>

using namespace std;
const int maxn = 1000+ 5;
int c[maxn], topo[maxn], g[maxn][maxn], t, n, m;

bool dfs(int u)
{
    c[u] = -1;//访问标志
    for (int v = 0; v < n; v++) {
        if (g[u][v]) {//如果u在v前面,只用看可能会出错的,而且要往后找
            if (c[v] < 0) return false;//如果v在访问中,说明出现了环
            else if (!c[v] && !dfs (v)) return false;//一直往下递归,看看有没有环,如果没有环的话,递归出的应该是最后一个
        }
    }
    c[u] = 1;//访问结束
    topo[--t] = u;//topo数组存储任务
    return true;
}

bool toposort()
{
    t = n;
    memset (c, 0, sizeof(c));
    for (int u = 0; u < n; u++)
        if (!c[u])
            if (!dfs (u))
                return false;
    return true;
}

int main()
{
    while (cin >> n >> m) {
        if (n == 0 && m == 0) break;
        //memset (topo, 0, sizeof(topo));
        memset (g, 0, sizeof(g));
        for (int i = 0; i < m; i++) {
            int a, b;
            cin >> a >> b;
            g[a - 1][b - 1] = 1;
        }
        toposort ();
        for (int i = 0; i < n; i++) {
            if (i) printf (" ");
            printf ("%d", topo[i] + 1);
        }
        printf ("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值