Duplicate Pair(异或操作)

181 篇文章 0 订阅
173 篇文章 3 订阅


Link:http://acm.fzu.edu.cn/problem.php?pid=1001


Problem 1001 Duplicate Pair

Accept: 4923    Submit: 23300
Time Limit: 1000 mSec    Memory Limit : 65536 KB

 Problem Description

An array of length n, with address from 1 to n inclusive, contains entries from the set {1,2,...,n-1} and there's exactly two elements with the same value. Your task is to find out the value.

 Input

Input contains several cases.
Each case includes a number n (1<n<=10^6), which is followed by n integers.
The input is ended up with the end of file.

 Output

Your must output the value for each case, one per line.

 Sample Input

21 141 2 3 2

 Sample Output

12

 Source

IBM Challenge 2004.1

AC code:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
int n,t,tt,x,ans;
int main(){
    while(scanf("%d",&n)==1){
       t=0;
       tt=0;
       while(n--){
        scanf("%d",&x);
        t^=x;
        tt^=n;
       }
        ans=t^tt;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值