wyh2000 and a string problem(模拟)

181 篇文章 0 订阅
171 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5284


wyh2000 and a string problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 177    Accepted Submission(s): 91


Problem Description
Young theoretical computer scientist wyh2000 is teaching young pupils some basic concepts about strings.

A subsequence of a string  s  is a string that can be derived from  s  by deleting some characters without changing the order of the remaining characters. You can delete all the characters or none, or only some of the characters.

He also teaches the pupils how to determine if a string is a subsequence of another string. For example, when you are asked to judge whether  wyh  is a subsequence of some string or not, you just need to find a character  w , a  y , and an  h , so that the  w  is in front of the  y , and the  y  is in front of the  h .

One day a pupil holding a string asks him, "Is  wyh  a subsequence of this string?"
However, wyh2000 has severe myopia. If there are two or more consecutive character  v s, then he would see it as one  w . For example, the string  vvv  will be seen as  w , the string  vvwvvv  will be seen as  www , and the string  vwvv  will be seen as  vww .

How would wyh2000 answer this question?
 

Input
The first line of the input contains an integer  T(T105) , denoting the number of testcases.

N  lines follow, each line contains a string.

Total string length will not exceed 3145728. Strings contain only lowercase letters.

The length of hack input must be no more than 100000.
 

Output
For each string, you should output one line containing one word. Output  Yes  if wyh2000 would consider  wyh  as a subsequence of it, or  No  otherwise.
 

Sample Input
  
  
4 woshiyangli woyeshiyangli vvuuyeh vuvuyeh
 

Sample Output
  
  
No Yes Yes No
 

Source
 


AC code:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
char s[3145730];
int T,l,i,fg1,fg2,fg3;
int main(){
    scanf("%d",&T);
    getchar();
    while(T--){
        gets(s);
        l=strlen(s);
        fg1=fg2=fg3=0;
        for(i=1;i<l;i++){
            if(s[i-1]=='w'||(s[i]=='v'&&s[i-1]=='v'))
                fg1=1;
            if(fg1&&s[i]=='y')
                fg2=1;
            if(fg2&&s[i]=='h'){
                 fg3=1;
                 break;
            }
        }
        if(fg3)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值