zoj1016 Parencodings(括号匹配变形:STL栈处理+模拟)

181 篇文章 0 订阅
90 篇文章 0 订阅


Link:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=16


Parencodings

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9


Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


Source:  Asia 2001, Tehran (Iran)


AC  code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<set> 
#define LL long long 
#define MAXN 1000010
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
stack<int>s;
string str;
int main()
{
	//freopen("D:\in.txt","r",stdin);
	int t,i,j,n,m,l,len,p;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		str="";
		l=0;
		while(n--)//还原源字符串 
		{
			scanf("%d",&m);
			for(i=1;i<=m-l;i++)
			{
				str+="(";
			}
			l+=(m-l);
			str+=")";
		}
		while(!s.empty())
			s.pop();
		len=str.length();
		int cnt=0;
		for(i=0;i<len;i++)//利用栈处理 
		{
			if(str[i]=='(')
			{
				s.push(1);
			}
			else
			{
				p=s.top();
				s.pop();
				if(cnt==0)
					printf("%d",p);
				else 
					printf(" %d",p);
				cnt++; 
				if(!s.empty())
					s.top()+=p;
			}
		}
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值