The Factor(数论规律题+求质因子)

173 篇文章 3 订阅
171 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5428



The Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 688    Accepted Submission(s): 229


Problem Description
There is a sequence of  n  positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead. 
 

Input
The first line contains one integer  T (1T15) , which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains one integer denoting the value of  n (1n100) .

2. The second line contains  n  integers  a1,,an (1a1,,an2×109) , which denote these  n  positive integers. 
 

Output
Print  T  answers in  T  lines.
 

Sample Input
  
  
2 3 1 2 3 5 6 6 6 6 6
 

Sample Output
  
  
6 4
 

Source
 

官方题解:

The Factor

对于每一个数字,它有用的部分其实只有它的所有质因子(包括相等的)。求出所有数的所有质因子中最小的两个,相乘就是答案。如果所有数字的质因子个数不到两个,那么就是无解。时间复杂度O(n*sqrt(a))O(nsqrt(a))

AC code:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <string>
#include <queue>
#include <stack>
#include <algorithm>
#define PI acos(-1.0)
#define LINF 1000000000000000000LL
#define eps 1e-8
#define LL long long
#define MAXN 1000010 
#define MOD 9901
using namespace std;
const int INF=0x3f3f3f3f;
//******************************************
//素数筛选和合数分解
int cnt;//质因子个数
long long ans;
LL b[MAXN];
LL a[111];
int main()
{
	int A,B,n;
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		cnt=0;
		for(i=1;i<=n;i++)
		{
			scanf("%I64d",&a[i]);
			for(int j=2;(LL)j*j<=a[i];j++){
				 while(a[i]%j==0){
				 	b[++cnt]=j;
				 	a[i]/=j;
				}
			}
			if(a[i]!=1){
				b[++cnt]=a[i];
			}
		}
		if(cnt>=2)
		{
			sort(b+1,b+cnt+1); 
			printf("%I64d\n",b[1]*b[2]);
		}
		else
		{
			printf("-1\n");
		}
	}
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值