HDU 5428 The Factor(分解质因子)

Problem Description

There is a sequence of n positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead.

Input

The first line contains one integer T (1≤T≤15), which represents the number of testcases.
For each testcase, there are two lines:
1. The first line contains one integer denoting the value of n (1≤n≤100).
2. The second line contains n integers a1,…,an (1≤a1,…,an≤2×109), which denote these n positive integers.

 Output

Print T answers in T lines.

 Sample Input

 

2 3 1 2 3 5 6 6 6 6 6

 Sample Output

 

6 4

<span style="font-family: "Courier New", Courier, monospace;">题意:求一列数的乘积的最小的两个质因子的积,如果积没有两个及以上个质因子,输出-1.</span>

思路:对每个数分解质因子,保存最小的两个质因子,可以用短除法,从2——sqrt(这个数).

本鶸:CE:1次 TLE:2次 RE:1次

TLE是因为没有从2——sqrt(这个数),而是直接2——这个数......开始还以为是短除法用错了,就打了个素数表,每次除一个素数,试了一下还是TLE,主要还是前面那个原因.

AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long ll;
int a[310],sizee;
int main()
{
    int T,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(a,0,sizeof a);
        sizee=0;
        while(n--)
        {
            int flag=0;
            scanf("%d",&m);
            for(int i=2;i<=sqrt(m+0.5);i++)
            {
                while(m%i==0)
                {
                    m/=i;
                    a[sizee++]=i;
                    flag++;
                    if(flag==2)
                        break;
                }
                if(flag==2)
                    break;
            }
            if(flag!=2&&m!=1)
                    a[sizee++]=m;
        }
        if(sizee<2)
            cout<<-1<<endl;
        else
        {
            sort(a,a+sizee);
            cout<<(ll)a[0]*a[1]<<endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值