HDU5461 Largest Point 贪心(2015acm沈阳网络赛)

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1274    Accepted Submission(s): 502


Problem Description
Given the sequence  A  with  n  integers  t1,t2,,tn . Given the integral coefficients  a  and  b . The fact that select two elements  ti  and  tj  of  A  and  ij  to maximize the value of  at2i+btj , becomes the largest point.
 

Input
An positive integer  T , indicating there are  T  test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106)  and  b (0|b|106) . The second line contains  n integers  t1,t2,,tn  where  0|ti|106  for  1in .

The sum of  n  for all cases would not be larger than  5×106 .
 

Output
The output contains exactly  T  lines.
For each test case, you should output the maximum value of  at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 


Source


题目大意:

给定一个序列,求a*ti^ti + b *tj最大值。要求(i != j).


解题思路:

由于题目数据非常大,所以估计时间复杂度只可能为O(n),所以我们可以将a*ti^ti + b *tj分成两部分(左右两部分)分别贪心求出最大值。因为i != j,所以必须记录一下下标,然后判断,如果下标不相等,max(左部分)+max(右部分),如果相等max(max(第二大的左部分)+max(右部分),max(左部分)+max(第二大的右部分)).


AC code:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

const int maxn = 5 * 100000 + 10;
const long long inf = 1e18;

struct point
{
    int pos;
    long long value;
}c[maxn],d[maxn];

bool cmp(struct point a,struct point b)
{
    return a.value > b.value;
}

int main()
{
    int T;
    int n,a,b;
    long long num,i;
    int cnt = 0;
    scanf("%d",&T);
    while(T--)
    {
        cnt++;
        scanf("%d%d%d",&n,&a,&b);
        for(i=0;i<n;i++)
        {
            scanf("%lld",&num);
            c[i].pos = i;
            d[i].pos = i;
            c[i].value = a * num * num;
            d[i].value = b * num;
        }
        sort(c,c+n,cmp);
        sort(d,d+n,cmp);
        long long temp1 = c[0].value;
        long long temp2 = d[0].value;
        long long temp3 = c[1].value;
        long long temp4 = d[1].value;
        printf("Case #%d: ",cnt);
        if(c[0].pos != d[0].pos)
        {
            printf("%lld\n",temp1 + temp2);
        }
        else
        {
            long long Max = -inf;
            if(temp1 + temp4 > Max)
            {
                Max = temp1 + temp4;
            }
            if(temp2 + temp3 > Max)
            {
                Max = temp2 + temp3;
            }
            printf("%lld\n",Max);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值