Largest Point

                                                                                Largest Point
                          Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
                                                    Total Submission(s): 0    Accepted Submission(s): 0
 Problem Description
Given the sequence A with n integers t1,t2,⋯,tn. Given the integral coefficients a and b. The fact that select two elements ti and tj of A and i≠j to maximize the value of at2i+btj, becomes the largest point.
 
Input
An positive integer T, indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2≤n≤5×106), a (0≤|a|≤106) and b (0≤|b|≤106). The second line contains n integers t1,t2,⋯,tn where 0≤|ti|≤106 for 1≤i≤n.
The sum of n for all cases would not be larger than 5×106.
 
Output
The output contains exactly T lines.

For each test case, you should output the maximum value of at2i+btj.
 


Sample Input
2


3 2 1
1 2 3


5 -1 0
-3 -3 0 3 3
 


Sample Output
Case #1: 20

Case #2: 0


AC代码:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<map>
using namespace std;
#define T 5100050
#define abs(a) a>0?a:-a 
typedef long long ll;

struct node
{
	ll val;
	int flag;
}t[T],Abs[T];
bool cmpmax(node& a,node& b)
{
	return a.val>b.val;
}
bool cmpmin(node& a,node& b)
{
	return a.val<b.val;
}
int bo[T];
int main()
{
	/*freopen("input.txt","r",stdin);*/
	ll n,m,a,b,i,cnt;
	ll sum;
	scanf("%lld",&n);
	for(cnt=1;cnt<=n;++cnt)
	{
		memset(bo,0,sizeof(bo));
		sum=0;
		scanf("%lld%lld%lld",&m,&a,&b);
		for(i=0;i<m;++i){
			scanf("%lld",&t[i].val);
			t[i].flag = i;
			Abs[i].val = abs(t[i].val);
			Abs[i].flag = i;
		}sort(t,t+m,cmpmax);
		sort(Abs,Abs+m,cmpmin);
		if(a==0){
			if(b>0)
				sum=b*t[0].val;
			else
				sum=b*t[m-1].val;
		}
		else if(a>0){
			sum=a*Abs[m-1].val*Abs[m-1].val;
			bo[Abs[m-1].flag]++;
			if(b>0){
				if(bo[t[0].flag]==0)
					sum+=b*t[0].val;
				else{
					sum+=b*t[1].val;
				}
			}
			else{
				if(bo[t[m-1].flag]==0){
				sum+=b*t[m-1].val;
				}
				else
				{
					sum+=b*t[m-2].val;
				}
			}
		}
		else{
			sum=a*Abs[0].val*Abs[0].val;
			bo[Abs[0].flag]++;
			if(b>0){
				if(bo[t[0].flag]==0){
					sum+=b*t[0].val;
				}
				else{
					sum+=b*t[1].val;
				}
			}
			else{
				if(bo[t[m-1].flag]==0){
					sum+=b*t[m-1].val;
				}
				else{
					sum+=b*t[m-2].val;
				}
			}
		}
		printf("Case #%lld: %lld\n",cnt,sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值