题目
Description
Input
Output
Sample Input
样例 1 输入
5 11 33
1 2 1 3 3
3 1 5
3 1 5
3 1 3
3 3 3
1 2 4 5
3 1 5
3 3 5
1 4 5 1
3 1 5
2 1 5
3 1 5
Sample Output
样例 1 输出
2 1 3
3 1 2 3
2 1 2
1 1
1 5
2 3 5
2 1 5
2 2 6
Data Constraint
思路
先考虑区间众数
可以使用消去算法。
即对于区间[L,R]扫一遍,维护一个数x和出现次数s
当前数=x则s+1,否则s-1,若s已为0则把x设为当前数
若区间内存在绝对众数,那么就算用其他的数和其抵消后仍然能剩余
因此最后的x就是可能的绝对众数(当区间内存在时)
推广到本题
推广到本题,设d=100/p下取整,对于线段树内每个区间维护d个可能的强国
显然一个国家在两个区间内都是弱国的话合并后不可能变成强国,因此可能的强国只有这2d个国家
合并一下,若合并后多于d个就把第d+1个去消前d个
原理同上,一个强国一次会消掉至少d个数,全部消完后还有剩余
代码
#include <bits/stdc++.h>
#define mp make_pair
#define pii pair<int,int>
using namespace std;
const int N = 1.5e5 + 1000;
vector<pii> t[N * 4];
int n,m,p,a[N];
int no,yjy[1000000];
int sz[N * 4],mx;
void merge(vector<pii> &a,const vector<pii> &b,const vector<pii> &c) {
no++;
for(pii p : b) yjy[p.second] += p.first;
for(pii p : c) yjy[p.second] += p.first;
a.clear();
for(pii p : b) {
int v = p.second;
if (yjy[v]) {
a.push_back(mp(-yjy[v],v));
yjy[v] = 0;
}
}
for(pii p : c) {
int v = p.second;
if (yjy[v]) {
a.push_back(mp(-yjy[v],v));
yjy[v] = 0;
}
}
sort(a.begin(),a.end());
for(int i = a.size() - 1; ~i; i--) a[i].first = -a[i].first;
while(a.size()>mx+1)a.pop_back();
if(a.size() == mx + 1) {
for(int i = 0; i < a.size() - 1; i++) {
a[i].first -= a.back().first;
}
a.pop_back();
}
}
void build(int x,int l,int r) {
sz[x] = r - l + 1;
if (l == r) {
t[x].push_back(mp(1,a[l]));
return;
}
build(x << 1,l,l + r >> 1);
build(x << 1 | 1,(l + r >> 1) + 1,r);
merge(t[x],t[x << 1],t[x << 1 | 1]);
}
void read(int &x) {
char c; while((c=getchar()) > '9' || c < '0');
x = c - '0'; while((c=getchar()) >= '0' && c <= '9') x = x * 10 + c - '0';
}
pii tag[N * 4];
void addtag(int x,int v) {
tag[x].second += v;
for(pii &p : t[x]) p.second += v;
}
void setvalue(int x,int v) {
tag[x] = mp(v,0);
t[x].clear(); t[x].push_back(mp(sz[x],v));
}
void down(int x)
{
if (tag[x].first != 0) {
setvalue(x << 1,tag[x].first);
setvalue(x << 1 | 1,tag[x].first);
tag[x].first = 0;
}
if (tag[x].second != 0) {
addtag(x << 1,tag[x].second);
addtag(x << 1 | 1,tag[x].second);
tag[x].second = 0;
}
}
void modify(int x,int l,int r,int tl,int tr,int id) {
if (l > tr || r < tl) return;
if (tl <= l && r <= tr) {
if (id == 0) {
addtag(x,1);
} else {
setvalue(x,id);
}
return;
}
down(x);
modify(x << 1,l,l + r >> 1,tl,tr,id);
modify(x << 1 | 1,(l + r >> 1) + 1,r,tl,tr,id);
merge(t[x],t[x << 1],t[x << 1 | 1]);
}
vector<pii> tmp;
void query(int x,int l,int r,int tl,int tr,vector<pii> &w) {
if (l > tr || r < tl) return;
if (tl <= l && r <= tr) {
tmp = w;
merge(w,tmp,t[x]);
return;
}
down(x);
query(x << 1,l,l + r >> 1,tl,tr,w);
query(x << 1 | 1,(l + r >> 1) + 1,r,tl,tr,w);
}
void write(vector<pii> a) {
for(pii b : a) {
cout << b.first << " " << b.second << endl;
}
cout << endl;
}
int main() {
freopen("war.in","r",stdin);freopen("war.out","w",stdout);
cin >> n >> m >> p;
mx = 100 / p;
for(int i = 1; i <= n; i++) read(a[i]);
build(1,1,n);
for(int i = 1; i <= m; i++)
{
int ty,l,r; read(ty),read(l),read(r);
if (ty == 1) {
int id; read(id);
modify(1,1,n,l,r,id);
}
else if (ty == 2) {
modify(1,1,n,l,r,0);
}
else if (ty == 3) {
static vector<pii> g;
g.clear();
query(1,1,n,l,r,g);
printf("%d ",g.size());
for(pii a : g)
{
printf("%d ",a.second);
}
printf("\n");
}
}
}