PAT A1078 Hashing

1078 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (10^4 ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

分析:本题的细节较多:

  1. 空格的控制,要求行末不得有多余空格
  2. 素数判断,0和1的特殊情况
  3. 循环探查记得及时退出,否则超时
  4. 哈希表的容量,虽然哈希的初始容量不大于10000,但哈希数组显然要大于这个数字,例如当Msize=9999时,显然这不是一个素数,需要向后探查下一个素数,这样容量会超过10000
  5. 当平方探查的步距和哈希的容量相当时,如仍然不能插入,则插入失败(证明略)
#include<iostream>
using namespace std;
bool isprime(int n) {
	if (n <= 1)
		return false;
	for (int i = 2;(i * i) <= n;i++) {
		if (n % i == 0)
			return false;
	}
	return true;
}
int main() {
	int tsize, num, a;
	cin >> tsize >> num;
	while (isprime(tsize)==false)
		tsize++;//查找到素数为止
	bool hash[10001] = { false };
	for (int i = 0;i < num;i++) {
		cin >> a;
		bool nopos = true;
		for (int step = 0;step < tsize;step++) {//当探查到tsize-1仍然找不到位置时,插入失败(证明略)
			if (hash[(a + step * step) % tsize] == false) {
				hash[(a + step * step) % tsize] = true;
				cout << (a + step * step) % tsize;
				nopos = false;
				break;//找到为止
			}
		}
		if (nopos==true)
			cout << "-";
		if (i != num - 1) 
			cout << " ";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值