购物车
Problem Description
各位亲爱的小伙伴们,大家好!
欢迎来到美美自助购物商场,首先请您帮忙建立商品信息,然后选购商品、确定数量,计算出总价格到结算中心进行结算。美美祝您购物愉快噢!
首先读取N行商品信息,每行包含:商品编号、商品名称、生产商、商品价格、库存数量;
接着输入M行购买信息:商品编号、商品数量、购买标志。
输出购物车中的商品数量T,以及T种商品的详细信息(商品编号、商品名称、生产商、商品价格、库存数量)、实际购买数量和购物车商品总价格(保留2位小数)。
美美商场友情提示:商品数量充分时,您才能购买;另外,您购物成功后,一定要记得增减商品库存数量噢!
Input
首行是商品种类的数量N;
接下来是N行的商品信息,每行商品信息为:商品编号、商品名称、生产商、商品价格、库存数量;
购物操作的次数M;
接下来是M行的商品购买操作的信息,每行购买信息为:商品编号、购买数量count(count>0)、购买标志(1--购买,购物车中该商品数量增加;2--退货,购物车中该商品数量减少,3-删除商品,删除操作时count列的值无效)。
Output
购物车中商品的数量T;
购物车中的所有商品详情,每种商品详情占一行,中间数据用1个空格符隔开。商品详情包括:商品编号、商品名称、生产商、商品价格、商品最新库存数量、已购买的商品数量。(商品价格保留2位小数),按照商品编号从小到大的顺序进行输出。若T=0,则无商品详情信息输出。
最后一行输出购物车中商品的总价格。(保留2位小数)
Sample Input
5 1 运动鞋 Adidas 300.80 10 2 蓝球服 李宁 268.00 10 3 苹果 栖霞 5.00 500 4 智能手表 苹果 4888.00 10 5 鼠标 罗技 120.00 50 9 1 5 1 3 5 1 4 1 1 3 2 2 5 2 1 1 2 1 5 0 3 3 1 1 3 5 2
Sample Output
2 1 运动鞋 Adidas 300.80 3 7 4 智能手表 苹果 4888.00 9 1 6993.60
Hint
1、购买商品的实际数量要小于或等于库存数量,退货时的数量要小于购物车中该商品的现有数量。
2、购买行为发生时,注意库存的变化。购买商品之后减库存,退货之后加库存。
3、购物车中某商品的实际数量为0时,就移除它。
Code
import java.text.DecimalFormat;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
Map<Integer, Product> map = new TreeMap<Integer, Product>();
DecimalFormat dlf = new DecimalFormat("0.00");
int N = sc.nextInt();
for (int i = 0; i < N; i++) {
int id = sc.nextInt();
Product p = new Product(id, sc.next(), sc.next(), sc.nextDouble(), sc.nextInt(), 0);
map.put(id, p);
}
int M = sc.nextInt();
double total = 0;
while (M-- != 0) {
int id = sc.nextInt();
int count = sc.nextInt();
int op = sc.nextInt();
Product goods = map.get(id);
if (op == 1) {
if (goods.sum >= count) { // 商品库存充足
goods.sum -= count;
goods.count += count;
map.put(id, goods);
} else { // 商品不足,只能拿走全部,商品存量为0
goods.count += goods.sum;
goods.sum = 0;
map.put(id, goods);
}
} else if (op == 2) {
if (goods.count > count) { // 购物车中的商品充足
goods.sum += count;
goods.count -= count;
map.put(id, goods);
} else { // 购物车中余量不足,全部退货,商品存量增加
goods.sum += goods.count;
goods.count = 0;
map.put(id, goods);
}
} else if (op == 3) {
goods.sum += goods.count;
goods.count = 0;
map.put(id, goods);
}
}
int k = 0;
for (Product p : map.values()) {
if (p.count > 0) {
k++;
}
}
System.out.println(k);
for (Product p : map.values()) {
if (p.count > 0) {
System.out.println(p);
total += p.price * p.count;
}
}
System.out.println(dlf.format(total));
sc.close();
}
}
class Product {
int id;
String name;
String produce;
double price;
int sum; // 商品库存
int count; // 购物车中的数量
DecimalFormat dlf = new DecimalFormat("0.00");
public Product(int id, String name, String produce, double price, int sum, int count) {
super();
this.id = id;
this.name = name;
this.produce = produce;
this.price = price;
this.sum = sum;
this.count = count;
}
@Override
public String toString() {
return id + " " + name + " " + produce + " " + dlf.format(price) + " " + sum + " " + count;
}
}
反思:
Java的综合练习。为了便于检索,使用TreeMap存商品信息。要注意商品库存和购物车中商品数量的及时更新。题目难度不大,但前前后后WA了好几次,怀疑人生……最后还是放弃了remove数量为0的商品,老老实实跑values遍历不为0的商品数量……再也不能愉快地购物了