sdut 3869 购物车

购物车

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

各位亲爱的小伙伴们,大家好!

欢迎来到美美自助购物商场,首先请您帮忙建立商品信息,然后选购商品、确定数量,计算出总价格到结算中心进行结算。美美祝您购物愉快噢!

首先读取N行商品信息,每行包含:商品编号、商品名称、生产商、商品价格、库存数量;

接着输入M行购买信息:商品编号、商品数量、购买标志。

输出购物车中的商品数量T,以及T种商品的详细信息(商品编号、商品名称、生产商、商品价格、库存数量)、实际购买数量和购物车商品总价格(保留2位小数)。

美美商场友情提示:商品数量充分时,您才能购买;另外,您购物成功后,一定要记得增减商品库存数量噢!

Input

首行是商品种类的数量N;

接下来是N行的商品信息,每行商品信息为:商品编号、商品名称、生产商、商品价格、库存数量;

购物操作的次数M;

接下来是M行的商品购买操作的信息,每行购买信息为:商品编号、购买数量count(count>0)、购买标志(1--购买,购物车中该商品数量增加;2--退货,购物车中该商品数量减少,3-删除商品,删除操作时count列的值无效)。

Output

购物车中商品的数量T;

购物车中的所有商品详情,每种商品详情占一行,中间数据用1个空格符隔开。商品详情包括:商品编号、商品名称、生产商、商品价格、商品最新库存数量、已购买的商品数量。(商品价格保留2位小数),按照商品编号从小到大的顺序进行输出。若T=0,则无商品详情信息输出。

最后一行输出购物车中商品的总价格。(保留2位小数)

Example Input
5
1 运动鞋  Adidas  300.80   10
2 蓝球服  李宁    268.00    10
3 苹果    栖霞    5.00	     500
4 智能手表  苹果  4888.00   10
5 鼠标   罗技     120.00    50
9
1 5 1
3 5 1
4 1 1
3 2 2
5 2 1 
1 2 1
5 0 3
3 1 1
3 5 2
Example Output
2
1 运动鞋 Adidas 300.80 3 7
4 智能手表 苹果 4888.00 9 1
6993.60
Hint

1、购买商品的实际数量要小于或等于库存数量,退货时的数量要小于购物车中该商品的现有数量。

2、购买行为发生时,注意库存的变化。购买商品之后减库存,退货之后加库存。

3、购物车中某商品的实际数量为0时,就移除它。




import java.util.*;

public class Main {

	static Scanner in = new Scanner(System.in);

	public static void main(String args[]) {

		Map<Integer, Goods> list = new TreeMap<Integer, Goods>();
		int n = in.nextInt();
		for (int i = 0; i < n; i++) {
			int id = in.nextInt();
			String name = in.next();
			String producer = in.next();
			double cost = in.nextDouble();
			int stock = in.nextInt();
			Goods goods = new Goods(id, name, producer, cost, stock);
			list.put(id, goods);
		}
		int t = in.nextInt();
		int[] a = new int[10000];
		for (int i = 0; i < a.length; i++) {
			a[i] = 0;
		}
		for (int i = 0; i < t; i++) {
			int id = in.nextInt();
			int count = in.nextInt();
			int symble = in.nextInt();

			if (symble == 1) {
				if (list.get(id).stock >= count) {
					list.get(id).stock -= count;
					a[id] += count;
				}
				else{
					a[id]+=list.get(id).stock;
					list.get(id).stock=0;
				}
			}
			if (symble == 2) {
				if(count>a[id]){
					list.get(id).stock+=a[id];
					a[id]=0;
				}else{
					a[id]-=count;
					list.get(id).stock+=count;
				}
			}
			if (symble == 3) {
				if (list.get(id).id == id) {
					list.get(id).stock += a[id];
					a[id] = 0;
				}
			}
		}

		int cnt = 0;
		for (Integer g : list.keySet()) {
			if (a[g] > 0) {
				cnt++;
			}
		}
		double sum = 0;
		System.out.println(cnt);
		for (Map.Entry<Integer,Goods> g : list.entrySet()) {
			if (a[g.getKey()] > 0) {
				System.out.print(g.getValue().id+"\t"+g.getValue().name+"\t"+g.getValue().producer+"\t");
				System.out.printf("%.2f", g.getValue().cost);
				System.out.println("\t"+g.getValue().stock+"\t"+a[g.getKey()]);
				sum += g.getValue().cost * a[g.getKey()];
			}
		}
		System.out.printf("%.2f", sum);
		System.out.println();
	}
}

class Goods {
	String name, producer;
	int id, stock;
	double cost;

	public Goods(int id, String name, String producer, double cost, int stock) {
		this.id = id;
		this.name = name;
		this.cost = cost;
		this.producer = producer;
		this.stock = stock;
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值