hdu5655 CA Loves Stick JAVA大数

11 篇文章 0 订阅
5 篇文章 0 订阅

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 130    Accepted Submission(s): 53


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains  T  denoting the number of testcases.
T  testcases follow. Each testcase contains four integers  a,b,c,d  in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

Source



如果边里面有0,则直接输出No,因为组不成四边形,如果有一条边的长度大于等于其他三条边的和,则输出No,否则输出Yes,long long都会爆,用double会损失

精度一样不行,还是JAVA大数比较方便


import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String [] args) {
        Scanner in = new Scanner(System.in);
        BigInteger num[] = new BigInteger[4];
        int T = in.nextInt();
        while (T-->0) {
            boolean flag = true;
            BigInteger sum = BigInteger.ZERO;
            for (int i = 0; i < 4; i++) {
                num[i] = in.nextBigInteger();
                if (num[i].equals(BigInteger.ZERO)) {
                    flag = false;
                }
                sum = sum.add(num[i]);
            }
            if (!flag) {
                System.out.println("No");
                continue;
            }
            for (int i = 0; i < 4; i++) {
                if (sum.subtract(num[i]).compareTo(num[i]) <= 0) {
                    flag = false;
                    break;
                }
            }
            if (flag) {
                System.out.println("Yes");
            } else {
                System.out.println("No");
            }
        }
        in.close();
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值