1213 How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18167    Accepted Submission(s): 8944


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4

题意,有个人要请客,请了很多朋友,规定,相互是朋友的就坐在一起,否则就需要另一个桌子.....

给出第一个数,代表几组测试数据,每组前两个数,表示一共多少人(编号从1~n),第二个数表示,这些人有多少关系,

下面几行就是这些关系对应的哪些人,也就是哪两个人认识.......


分析:

这个相当于统计一共有多少个集合的问题,用并查集,只要统计出有多少父节点(就是多少堆人),也就统计出来了需要多少桌子......


#include<stdio.h>
#include<string.h>
int per[1005];
void init(int n)//初始化
{
    for(int i=1;i<=n;++i)
    {
        per[i]=i;
    }
}
int find(int x)
{
    int r=x;
    while(per[r]!=r)//查找
    {
        r=per[r];
    }
    int i=x,j;
    while(i!=r)//压缩路径
    {
        j=per[i];per[i]=r;i=j;
    }
    return r;
}
void join(int x, int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)//合并
    {
        per[fx]=fy;
    }
}
int main()
{
    int t,n,m,i,a,b,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(n);c=0;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        for(i=1;i<=n;++i)
        {
            if(per[i]==i)//查找父节点.....
            {
                ++c;
            }
        }
        printf("%d\n",c);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值