Silver Cow Party POJ - 3268 最短路

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

求所有牛到牛X的最短路和回去的最短路之和的最大值。网上好多题解求回去的最短路都是用矩阵转置写的。看到了一个大佬的比较省时间的方法,存的时候反着存。

#include<iostream>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1010;
int mp[maxn][maxn];
int vis[maxn];
int dis[maxn];
int ddis[maxn]; 
int n,m,x;
int dij()
{
	int v,mi,i,j,k;
	for(i=1;i<=n;i++)
	{
		vis[i]=0;
		dis[i]=mp[x][i]; 
		ddis[i]=mp[i][x];  //回去时候的最短路,反着存图 
	}
	for(i=1;i<=n;i++)
	{
		mi=inf;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&dis[j]<mi)
			{
				v=j;
				mi=dis[j];
			}
		}
			vis[v]=1;
			for(k=1;k<=n;k++)
			{
				if(!vis[k]&&dis[k]>dis[v]+mp[v][k])
				{
					dis[k]=dis[v]+mp[v][k];
				}
			}	
	}
	for(i=1;i<=n;i++)
	{
		vis[i]=0;
	}
	for(i=1;i<=n;i++)
	{
		mi=inf;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&ddis[j]<mi)
			{
				v=j;
				mi=ddis[j];
			}
		}
			vis[v]=1;
			for(k=1;k<=n;k++)
			{
				if(!vis[k]&&mp[k][v]+ddis[v]<ddis[k])
				{
					ddis[k]=ddis[v]+mp[k][v];
				}
			}	
	}
	mi=-1;
	for(i=1;i<=n;i++)
	{
		if(dis[i]+ddis[i]>mi)
		{
			mi=dis[i]+ddis[i];
		}
	}
	return mi;
}
int main()
{
	//freopen("C:/input.txt", "r", stdin);
	while(~scanf("%d%d%d",&n,&m,&x))
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(i!=j)
				{
					mp[i][j]=inf;
				}
				else
				{
					mp[i][j]=0;
				}
			}
		}
	
		for(int i=1;i<=m;i++)
		{
			int u,v,l;
			scanf("%d%d%d",&u,&v,&l);
			mp[u][v]=l; 
		} 
		printf("%d\n",dij());
	}
	return 0;
}

这个题就是求两遍最短路,用两遍dij就行,然后用两个数组存下最短路,最后遍历一遍求出最大值输出就行了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值