A + B Problem II(HDU1002)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 138369    Accepted Submission(s): 26247


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
1 2 
112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1:
1 + 2 = 3 
 
Case 2: 
112233445566778899 + 998877665544332211 = 1111111111111111110
 

解题思路:两个相加的数分别用两个字符数组储存 , 再用两个整型数组将两个相加的数从个位开始存起来 , 然后再相加,满十进位 ;
特殊数据:1 ,999 ; 1 , 11 ; 1 , 99 ;0 , 0 ; 00 , 09 ;
注意:不用考虑最高位为0 ,例如00和09输出 00 + 09;
错误经历:(菜鸟,高手勿喷)一开始我把两个字符数组初始化为 ‘0’ ,然后定义一个整型数组直接把数储存起来;后来测试1 , 99 数据时, 结果为1-3-9 ;因为字符数组输入后最后一个是 ‘\n’ ,导致十位的 9 跟 '\n' 是相加不了;
代码
#include <iostream>
#include <cstring>
using namespace std;

int max(int x , int y)
{
 return x > y? x : y;
}
int main()
{
 int T , m , i , j , s;
 char a[1005] , b[1005];
 int  num1[1005], num2[1005];
 scanf("%d" , &T);
 m = 1;
 while(T--)
 {
  memset(num1 ,0, sizeof(num1));
  memset(num2 ,0, sizeof(num2));
  scanf("%s%s", a , b);

  int len1 = strlen(a) , len2 = strlen(b);

  for(i = len1-1 ,j = 0 ; i >= 0 ; i--)//将字符数组里的数存在整型数组里;
   num1[j++] = a[i] - '0';

  for(i = len2-1  , j = 0; i>=0 ; i--)//将字符数组里的数存在整型数组里;
   num2[j++] = b[i] - '0';

  int k = max(len1 , len2);//比较两个相加的数长度的大小;

  for(i = 0 , j = 0 ; i < k ; i++)
  {
   s = num1[i] + num2[i] ;
   num1[j] = s%10;
   num1[j+1] = s/10 + num1[j+1];
   j++;
  }

  while(num1[j] == 0 && j > 0)//去除最高位的零
   j--;

  printf("Case %d:\n" , m++);
  printf("%s + %s = " , a , b);
  for(i = j ; i >= 0 ; i--)
   printf("%d" ,num1[i]);
  printf("\n");
  if(T != 0)
   printf("\n");
 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值