Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 70207 Accepted Submission(s): 16285
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
解题思路:先打表 , 再输出 ,这题有规律 ,每到48 , 循环一次 。
代码:
#include <iostream>
using namespace std;
int f[10000];
int main()
{
int n ;
int a , b , i;
f[1] = f[2] = 1;
while(scanf("%d%d%d" , &a , &b ,&n)!=EOF)
{
if(a == 0 && b == 0 && n == 0)
break;
for( i = 3 ; i <= 96 ; i++)//打表;
{
f[i] = (a*f[i-1] +b*f[i-2])%7;
}
n = n%48;//每48个数循环一次;
printf("%d\n" ,f[n]);
}
return 0;
}