Number Sequence hdu 1005(循环节)

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3 1 2 10 0 0 0

Sample Output

2 5

 

思路:打表一下是存在循环节的,因为mod = 7,所以f(n)最多又49个值, 有公式可知,每个数取决于前面两个数,

设 i, j,i < j 若存在f(j) == f(i) && f(j - 1) == f(i - 1) ,则接下来的发展是相同的,注意:循环节不一定从f(1)开始。由于最多只有49个数,所以我们可以在50个数之内找到循环节

 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include <map>
using namespace std;
const int MAX = 3000;
typedef long long LL;

int res[MAX];
int main(){
	res[1] = res[2] = 1;
	/*freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);*/
	while(1){
		int a, b, n;
		scanf("%d%d%d", &a, &b, &n);
		if(a == 0 && b == 0 && n == 0){
			break;
		}
		int le, ri;
		for(int i = 3; i < 60; i++){
			res[i] = (a * res[i - 1] + b * res[i - 2]) % 7;
			for(int j = 2; j < i - 1; j++){
				if(res[j] == res[i] && res[j - 1] == res[i - 1]){
					le = j - 1, ri = i -2;
				}
			}
		}
		n -= le - 1;
		int d = n % (ri - le + 1);
		if(n == 0){
			printf("%d\n", res[ri]);
		} else{
			printf("%d\n", res[le + d - 1]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值