PAT (Advanced Level) Practice 1015 Reversible Primes(20分)【数学:素数】

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N ( < 1 0 5 ) N (<10^5) N(<105) and D ( 1 < D ≤ 10 ) D(1<D≤10) D(1<D10), you are supposed to tell if N N N is a reversible prime with radix D D D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N N N and D D D. The input is finished by a negative N N N.

Output Specification:

For each test case, print in one line Yes if N N N is a reversible prime with radix D D D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意

给出正数N和进制radix,如果N在十进制下是素数,且N转换为radix进制并且反转后的数在十进制下也是素数,则输出Yes,否则输出No

怎么写都很别扭……

代码

#include <cstdio>
#include <cmath>

bool isPrime(int n) {
    if (n <= 1) return false;
    for (int i = 2, sqr = sqrt(n); i <= sqr; ++i)
        if (n % i == 0) return false;
    return true;
}

int d[111];

int main () {
    int n, radix;
    while (scanf("%d", &n) != EOF) {
        if (n < 0) break;  // n 是负数时退出循环
        scanf("%d", &radix);

        if (not isPrime(n))  // n 不是素数,输出 No,结束
            printf("No\n");
        else {
            int len = 0;

            do {  // 转换为raidx进制,同时逆序
                d[len++] = n % radix;
                n /= radix;
            } while (n != 0);

            for (int i = 0; i < len; ++i)  // 计算这个数在十进制下的值
                n = n * radix + d[i];

            if (isPrime(n)) printf("Yes\n");
            else printf("No\n");
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值