PAT (Advanced Level) Practice — 1015 Reversible Primes (20 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805495863296000

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

:题意  给出一个数字n,判断他是否为素数 并且 在d进制下翻转后的数字转化为十进制后是否为素数,这两者都满足,输出Yes,否则输出No

#include<iostream>
#include<cmath>
using namespace std;
int ans=0;
bool prim(int x){
	if(x==1){
		return false;
	}
	for(int i=2;i<=sqrt(x);i++){
		if(x%i==0){
			return false;
		}
	}
	return true;
}
int main(){
	int n,r;
	while(cin>>n){
		if(n<0){
			break;
		}
		cin>>r;
		if(prim(n)==false){
			cout<<"No"<<endl;
			continue;
		}
		int len=0;
		int a[111];
		//十进制转r进制,除k取余法 
		do{
			a[len++]=n%r;
			n/=r;
		}while(n!=0);
		//翻转后的r进制数字转为10进制 
		int k=1; 
		for(int i=len-1;i>=0;i--){
			n+=a[i]*k;
			k*=r;
		}
		if(prim(n)){
			cout<<"Yes"<<endl;
		} else{
			cout<<"No"<<endl;
		}
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值