PAT (Advanced Level) Practice 1028 List Sorting(25分)【排序】

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N ( ≤ 1 0 5 ) N (≤10^5) N(105) and C C C, where N N N is the number of records and C C C is the column that you are supposed to sort the records with. Then N N N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N N N lines. That is, if C C C = 1 then the records must be sorted in increasing order according to ID’s; if C C C = 2 then the records must be sorted in non-decreasing order according to names; and if C C C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题意

给出一些数据,将这些数据按照不同的依据排序后输出。

思路

可以用一个变量来控制比较函数,而比较函数只写一个,这样就避免了需要编写多个比较函数的复杂。

代码

#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

struct stu {
    static int c;
    string s[3];

    bool operator<(const stu &x) {
        if (s[c - 1] != x.s[c - 1])
            return s[c - 1] < x.s[c - 1];
        else return s[0] < x.s[0];
    }
} stu[100010];

int stu::c = 1;

int main() {
    int n;
    cin >> n >> stu::c;
    for (int i = 0; i < n; i++)
        for (int j = 0; j < 3; ++j)
            cin >> stu[i].s[j];

    sort(stu, stu + n);

    for (int i = 0; i < n; ++i)
        for (int j = 0; j < 3; ++j)
            cout << stu[i].s[j] << (j == 2 ? "\n" : " ");
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值