PAT (Advanced Level) Practice 1085 Perfect Sequence(25分)【二分查找、双指针】

Given a sequence of positive integers and another positive integer p p p. The sequence is said to be a p e r f e c t s e q u e n c e perfect sequence perfectsequence if M ≤ m × p M≤m×p Mm×p where M M M and m m m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p p p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N N N and p p p, where N ( ≤ 1 0 5 ) N (≤10^5) N(105) is the number of integers in the sequence, and p ( ≤ 1 0 9 ) p (≤10^9) p(109) is the parameter. In the second line there are N N N positive integers, each is no greater than 1 0 9 10^9 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

题意

给一组数,从这些数中选出一些数,使其最大值不超过最小值的p倍。求所有选法中含有数字最多的选法所含的数字的个数。

思路

思路1 二分查找

排序后遍历,对于每一个数,把它当成最小值,用二分查找的方式寻找满足条件的最大值,用这个选法中所含数字的个数更新答案。

思路2 双指针

排序后将两个指针i,j都放到0的位置,先右移j,直到不满足条件;再右移i,直到满足条件;如此往复,记录出现过的最大值。
注意:所有的数字都小于10^9,但是每个数字的p倍可能会超过int的范围。

代码

思路1
#include <algorithm>
#include <cstdio>

using namespace std;

long long a[100005];

int main() {
    int n, p;
    scanf("%d %d", &n, &p);
    for (int i = 0; i < n; ++i)
        scanf("%lld", &a[i]);

    sort(a, a + n);

    int r = 0;
    for (int i = 0; i < n; ++i)
        r = max(r, int(upper_bound(a, a + n, a[i] * p) - (a + i)));
    printf("%d", r);
}
思路2
#include <algorithm>
#include <cstdio>

using namespace std;

long long a[100005];

int main() {
    int n, p;
    scanf("%d %d", &n, &p);
    for (int i = 0; i < n; ++i)
        scanf("%lld", &a[i]);

    sort(a, a + n);

    int r = 0;
    for (int i = 0, j = 0; j < n;) {
        while (j < n && a[i] * p >= a[j])
            ++j;
        r = max(r, j - i);
        while (j < n && a[i] * p < a[j])
            ++i;
    }

    printf("%d", r);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值