A - How Many Answers Are Wrong +Zjnu Stadium(带权并查集)

TT and FF are … friends. Uh… very very good friends -__-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
Output
A single line with a integer denotes how many answers are wrong.
Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1

从今天上午就开始看了,一直到现在才稍微懂了点~
还要注意区间的相加(开闭区间)~

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 1212111
int pre[MAXN];//记录父节点
int num[MAXN];//记录权值
int find(int a)//寻找前一个节点
{
    if(a!=pre[a])
    {
        int t = pre[a];
        pre[a] = find(pre[a]);
        num[a] += num[t];//改变值的大小
    }
    return pre[a];
}
int merge(int a, int b, int c)
{
    a--;
    int aa = find(a);
    int bb = find(b);
    if(aa==bb)
    {
       if(num[b]-num[a] != c)//如果此时不相等,则错误
                return 0;
       else
        return 1;
    }
    else
    {
        pre[bb] = aa;
        num[bb] = num[a] - num[b] + c;//更新
        return 1;
    }
}
int main()
{
    int n, m, a, b, c;
    while(~scanf("%d %d", &n, &m))
    {
        int ans = 0;
        for(int i=0;i<=n;i++)
        {
            pre[i] = i;
            num[i] = 0;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d", &a, &b, &c);
            if(!merge(a, b, c))
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}

还有一道相似的题目~

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3915 Accepted Submission(s): 1497

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.

Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output
2
Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

Source
2009 Multi-University Training Contest 14 - Host by ZJNU

代码简直是不能再相似了,只要去掉一句就好~

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 1212111
int pre[MAXN];//记录父节点
int num[MAXN];//记录权值
int find(int a)//寻找前一个节点
{
    if(a!=pre[a])
    {
        int t = pre[a];
        pre[a] = find(pre[a]);
        num[a] += num[t];//改变值的大小
    }
    return pre[a];
}
int merge(int a, int b, int c)
{
    //a--;
    int aa = find(a);
    int bb = find(b);
    if(aa==bb)
    {
       if(num[b]-num[a] != c)//如果此时不相等,则错误
                return 0;
       else
        return 1;
    }
    else
    {
        pre[bb] = aa;
        num[bb] = num[a] - num[b] + c;//更新
        return 1;
    }
}
int main()
{
    int n, m, a, b, c;
    while(~scanf("%d %d", &n, &m))
    {
        int ans = 0;
        for(int i=0;i<=n;i++)
        {
            pre[i] = i;
            num[i] = 0;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d", &a, &b, &c);
            if(!merge(a, b, c))
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值