D - How Many Answers Are Wrong

抵达时抵达---题目链接 

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

猛然一看这题跟并查集貌似没有什么毛线关系啊,不过仔细观察可以发现既然要判断矛盾就肯定知道与以前的数据有冲突的地方,因为没有说这个数列是不是正整数所以冲突的方式只有一种,比如先说了连个区间

1-10 10

1-5 2

6-10 5

跟明显第三句话就可以看出来问题了,第二个加第三个跟第一个不相等,但是他们表述的区间都是相同的,所以产生矛盾,不过这种矛盾应该怎么判断呢,我们可以以它的端点为点建立一个集合,他们的根就是能到达的最左端,如果都有相同的最左端那么就可以判断一下是否有矛盾产生。


比如上面这个图, 我们已经知道了AB的长度和AC的长度,如果下面再来一个CB,我们就可以知道C的最左端是A,B的最左端也是A,那么就可以判断一个AC+CB的长度是不是等于AB的长度就可以了。。。。

如果最左端不相同的话合并的时候要先比较一下最左端是哪个

对于A~B之间的和是S,其实可以理解成B比A-1大S;

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=200001;
int f[maxn];
int val[maxn];
int find(int t)
{
    if(f[t]==-1)return t;
    int ans=find(f[t]);
            val[t]+=val[f[t]];
    return f[t]=ans;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,-1,sizeof(f));
        memset(val,0,sizeof(val));
        int ans=0;
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            a=a-1;
            int t1=find(a);
            int t2=find(b);
            if(t1!=t2)
            {
                f[t2]=t1;
                val[t2]=val[a]-val[b]+c;
            }
            else
            {
                if(val[b]-val[a]!=c)
                    ans++;

            }

        }
        printf("%d\n",ans);

    }

    return 0;
}

给出n,m,下面m行每一行有三个数,a,b,v,v代表的是区间【a,b】的和,每一行都是这样,但是当第i行与前i-1行发生冲突的时候,记录一下。输出共错误多少句。举个例子:第一行是 1 100 200,第二行是1 50 300,这就发生了冲突。 
【思路】 
http://blog.csdn.net/dextrad_ihacker/article/details/51016017 
这个大佬的博客写的很清晰(有配图),很容易理解。以下是我的个人见解(当然,也只是对大佬的话语的重复)。 
首先,要理解第i行,a,b,v,假设用dis代表距离,那么dis(a-b)=v;但是前i-1行不一定有一模一样的a,b,v,所以就要借助一个过渡,假设是c,那么就可以这样:dis(a-c)-dis(b-c)=v,有没有发现如果我们把他们共同的根节点也就是祖先,当做c的话,只需要知道节点a到祖先的距离,节点b到祖先的距离,就可以知道a和b的距离了(假设他们有共同的祖先),那如果a和b没有共同的祖先,那么在之前就找不到他们俩的关系,就不能确定dis(a-b)=v这个关系为假。就可以把他们的父节点连在一起,即把他俩各自的祖先弄到一起,比如把a的祖先拿去给b的祖先当父亲。 
还有一点,给出的是一个闭区间,【a,b】,但是他可以转化为(a-1,b],左开右闭。半闭半开区间有一个性质,就是 (a,b]+(b,c]=(a,c]; 
还有一点灰常重要的东西是怎么求a,b之间的距离。 
假如一开始没关系,那么用rank数组来表示a,b各自到各自祖先的距离。那么在把a的祖先给b的祖先当父亲之后,那么b到祖先的距离也就是rank【b】就要再加上b原本的祖先到a的祖先的距离,更新一下,其中find函数(找根节点的函数)里rank【x】+=rank【pre【x】】(这里pre数组存的是对应数的父节点)

 

好的,以下是代码形式的电话线路图状态: ``` @startuml title Telephone State Diagram [*] --> Idle : Initial State Idle --> Dialing : Off Hook Event Dialing --> Connecting : Valid Number Event Dialing --> Disconnected : Invalid/Wrong Number Event Connecting --> TimeOut : Timeout Event Connecting --> Connected : Called Phone Answers Event Ringing --> Connected : Called Phone Answers Event Connected --> Idle : On Hook Event Connected --> Busy Tone : Line Busy Event Connected --> TimeOut : Timeout Event Connected --> Disconnected : Timeout Event Connected --> Ringing : Play Message Event @enduml ``` 解释一下: - 初始状态为空闲状态(`[*] --> Idle : Initial State`)。 - 当电话机摘机时,电话状态从空闲状态转入拨号状态(`Idle --> Dialing : Off Hook Event`)。 - 当拨号有效号码时,电话状态从拨号状态转入连接状态(`Dialing --> Connecting : Valid Number Event`)。 - 当拨号号码无效或错误时,电话状态从拨号状态转入未连接状态(`Dialing --> Disconnected : Invalid/Wrong Number Event`)。 - 当连接超时时,电话连接状态从连接状态转入超时状态(`Connecting --> TimeOut : Timeout Event`)。 - 当被拨打的电话接听时,电话连接状态从连接状态或响铃状态转入已连接状态(`Connecting --> Connected : Called Phone Answers Event` 或 `Ringing --> Connected : Called Phone Answers Event`)。 - 当已连接状态的电话机挂机时,电话状态从已连接状态转入空闲状态(`Connected --> Idle : On Hook Event`)。 - 当已连接状态的电话线路忙碌时,电话状态从已连接状态转入忙音状态(`Connected --> Busy Tone : Line Busy Event`)。 - 当已连接状态的电话连接超时时,电话状态从已连接状态转入未连接状态(`Connected --> TimeOut : Timeout Event`)。 - 当已连接状态的电话播放信息时,电话状态从已连接状态转入响铃状态(`Connected --> Ringing : Play Message Event`)。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值