N - 畅通工程再续 (Kruskal)

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;
int x[12121];
int pre[121211];//祖先
int y[12121];
struct node
{
    int u, v;//两个岛
    double d;//距离,注意>=10&&<=1000
} t[12121];
int n;
int root(int a)
{
    while(a!=pre[a])
        a = pre[a];
    return a;
}
int Merge(int a, int b)
{
    int X = root(a);
    int Y = root(b);
    if(X!=Y)
    {
        pre[Y] = X;
        return 1;
    }
    return 0;
}
int cmp(struct node a, struct node b)
{
    return a.d<b.d;
}
double dis(int x1, int y1, int x2, int y2)//求距离
{
    double xx = x1 - x2;
    double yy = y1 - y2;
    double k = sqrt(xx*xx+yy*yy);
    return k;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n;
        int top = -1;
        for(int i=1; i<=n; i++)
        {
            cin>>x[i]>>y[i];
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                double m = dis(x[i], y[i], x[j], y[j]);
                if(m>=10&&m<=1000)//满足要求,加入
                {
                    top++;
                    t[top].d = m;
                    t[top].u = i;
                    t[top].v = j;
                }
            }
        }
        sort(t, t+top+1, cmp);//排序
        for(int i=0; i<=n; i++)//初始化
        {
            pre[i] = i;
        }
        double sum = 0;
        int num = 0, flag = 0;
        for(int i=0; i<=top; i++)
        {
            if(Merge(t[i].u, t[i].v))//合并
            {
                num++;
                sum += t[i].d;
                if(num==n-1)//记录边数,看是否连通
                {
                    flag = 1;
                    break;
                }
            }
        }
        if(flag)
            printf("%.1f\n", sum*100);
        else
            printf("oh!\n");

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值