Discovering Gold(基础概率dp)

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input
3

1
101

2
10 3

3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15

概率的题目,算是自己刷的第一道。
给出n个点,每个点都有金子,然后从第一个点开始,每次进行掷骰子,6个面的,然后按照骰子上面的显示数字走几步,注意,要是骰子上的步数在隧道外,则重新投掷。

假定在最后一个地方,则获得的数目为dp[i];
在n-1个地方,则获得的数目为dp[i]+dp[i+1];(骰子数目有1种情况)
在n-2个地方,。。。。。。。dp[i]+dp[i+1]/2+dp[i+2]/2(骰子数目有两种情况)
…………………..

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <cstring>
#include <cstdlib>
#include <vector>
using namespace std;
double dp[123123];
int main()
{
    int t;
    scanf("%d", &t);
    for(int T=1;T<=t;T++)
    {
        int n;
        scanf("%d", &n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf", &dp[i]);
        }
        for(int i=n-1;i>=1;i--)
        {
            int k = min(6, n-i);
            double temp = 0;
            for(int j=i+1;j<k+i+1;j++)
                temp += dp[j];
            dp[i] = dp[i] + temp/k;
        }
        printf("Case %d: %lf\n", T, dp[1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值