线性搜索

Linear Search

You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input

In the first line n is given. In the second line, n integers are given. In the third lineq is given. Then, in the fourth line, q integers are given.

Output

Print C in a line.

Constraints

  • n ≤ 10000
  • q ≤ 500
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
3 1 2
1
5

Sample Output 2

0

Notes

题目要求我们统计同时存在于两个集合的元素个数,我们只要先用数组记录一个集合,在输入第二个集合时每次输入都遍历查找一遍集合一就可以了。

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;

const int  maxn = 10000 + 5;

int a[maxn];
int sum = 0;
int n;

bool find(int key){
  for(int i = 1;i <= n; i++){
    if(a[i] == key)return true;
  }
  return false;
}

int main(){
  scanf("%d",&n);
  for(int i = 1;i <= n; i++){
    scanf("%d",&a[i]);
  }
  int q;
  scanf("%d",&q);
  for(int i = 1;i <= q; i++){
    int x;
    scanf("%d",&x);
    if(find(x)){
      sum++;
    }
  }
  printf("%d\n",sum);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值