E - The Triangle

E - The Triangle

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

解题思路:

因为需要找到顶部到底部的一条和最大的路径,我们可以把他们的每一层视为一个阶段,而他的目前的值视为状态,假如我们用一个二维数组f[i][j]表示从最底层到第i行第j列的最大路径总和,可以发现,当前的f[i][j]只可能由f[i+1][j]和f[i+1][j+1]过度过来。因为我们是要求最大值,所以能得到动态转移方程:

f[i][j]=max(f[i+1][j],f[i+1][j+1])+ch[i][j]

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 110;

int ch[maxn][maxn];
int f[maxn];

void dp(int m)
{
    for(int i = 1;i <= m; i++)f[i] = ch[m][i];
    for(int i = m-1;i >= 1; i--)
    {
        for(int j = 1; j <= i; j++)
        {
            f[j] = max(f[j],f[j+1])+ch[i][j];
        }
    }
}

int main()
{
        int m;
        scanf("%d",&m);
        for(int i = 1;i <= m; i++)
        {
            for(int j = 1;j <= i; j++)
            {
                scanf("%d",&ch[i][j]);
            }
        }
        dp(m);
        printf("%d\n",f[1]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值