Balancing Act

Balancing Act

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

这里写图片描述
Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed. 

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node. 

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题目大意:

给一个树,删除其中一个点就会形成一个森林,点的平衡度为删除了这个节点后,所形成多个树,其中组成树的节点最多,节点个数就是那个平衡度。

题目解析:

这道题说白了就是求树的重心.

下面先给出树的重心的定义:对于一棵n个节点的无根树,找到一个点使得把树变成一棵以该节点为根的有根树,这时的最大子树的节点数最小。

定义 f[i] 表示i的最大子树的节点数,定义 dp[i] 为以i为根的最大子树的节点数。然后递归求解。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 20000 + 5;

struct Edge{
    int next,to;
}G[maxn<<1];

int n,x;
int head[maxn],cnt;
int sum,f[maxn],dp[maxn];

void Insert(int u,int v){
    G[++cnt].next = head[u];
    G[cnt].to = v;
    head[u] = cnt;
}

void dfs(int u,int fa){
    int num = 0;
    f[u] = 1;
    for(int e = head[u];e; e = G[e].next){
        int v = G[e].to;
        if(v == fa)continue;
        dfs(v,u);
        f[u] += f[v];
        num = max(num,f[v]);
    }
    dp[u] = max(num,n-f[u]);
    if(sum > dp[u]){
        x = u;
        sum = dp[u];
    }
}

void init(){
    sum = 0x3f3f3f3f;
    cnt = 0;
    memset(f,0,sizeof(f));
    memset(head,0,sizeof(head));
    memset(dp,0,sizeof(dp));
}

int main(){
    int T,u,v;
    scanf("%d",&T);
    while(T--){
        init();
        scanf("%d",&n);
        for(int i = 0;i < n-1; i++){
            scanf("%d%d",&u,&v);
            Insert(u,v);
            Insert(v,u);
        }
        dfs(1,-1);
        printf("%d %d\n",x,dp[x]);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值