S - Balancing Act

S - Balancing Act

 
Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 
Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1
Sample Output
1 2
题目解析:
就是去掉一个点后剩下的所有的其它的子树中各数最多的最小的那个。
代码:

/*最近做的所有题,其实都是将无根树转化为有根树,
因为如果是一棵无根树,那么对每个点进行查找的时候就会产生重叠,
导致复杂度升高。
所以我们将其看作一棵有根树,
然后从根节点开始查找所有的子节点的子树(递归实现)
,父节点的子树则用总点数减去(该点子节点和+1)来判断。
*/
#include<iostream>
#include<string.h>
#include<algorithm>
#define MAX 22000
using namespace std;
struct edge
{
    int v;
    int next;
}edge[MAX*2];
int next[MAX];
int sum[MAX];
int dp[MAX];


int ans,n,num;
void add_edge(int u,int v)
{
    edge[num].next=next[u];
    next[u]=num;
    edge[num++].v=v;
}




void dfs(int father,int u,int n)
{
    int v,m,temp;
    for(int i=next[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].v;
        if(v==father)
            continue;
        dfs(u,v,n);
        sum[u]+=sum[v];
    }
  //  cout<<u<<": "<<sum[u]<<endl;
    dp[u]=n-1-sum[u];
    for(int i=next[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].v;
        if(v==father)
            continue;
        dp[u]=max(dp[u],sum[v]);
    }
    sum[u]++;
}
int main()
{
    int t;
    int p,q;
    cin>>t;
    while(t--)
    {
        cin>>n;
        num=0;
        memset(sum,0,sizeof(sum));
        memset(next,-1,sizeof(next));
        for(int i=0;i<n-1;i++)
        {
            cin>>p>>q;
            add_edge(p,q);
            add_edge(q,p);
        }
        ans=1<<29;
        p=0;
        dfs(0,1,n);
        for(int i=1;i<=n;i++)
        {
            if(dp[i]<ans)
            {
                ans=dp[i];
                p=i;
            }
        }
        cout<<p<<" "<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值