矩阵快速幂——Fibonacci ( POJ 3070 )

题目:
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

这里写图片描述

Given an integer n, your goal is to compute the last 4 digits of Fn.

输入:
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

输出:
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input:
0
9
999999999
1000000000
-1

Sample Output:
0
34
626
6875

和快速幂取模一样,使用二分的方法求幂降低时间复杂度。一次矩阵相乘是O(n^3)的时间复杂度(基本上优化不了多少),矩阵的b次就是O(n^3 * b)的时间复杂度,通过快速幂降低到O(n^3 * logb)。

PS:因为题目给定了范围(最后只要4为数),所以大数做乘法运算的时候记得要取模,否则会爆。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define mod 10000
//矩阵
struct Mat
{
    long long int mat[2][2];
};

//矩阵乘法
Mat operator * (Mat a, Mat b)
{
    Mat c;
    c.mat[0][0] = 0;
    c.mat[1][0] = 0;
    c.mat[0][1] = 0;
    c.mat[1][1] = 0;
    for(int k=0;k<2;k++)
    {
        for(int i=0;i<2;i++)
        {
            for(int j=0;j<2;j++)
            {
                c.mat[i][j] += a.mat[i][k] %mod* b.mat[k][j] %mod;
            }
        }
    }

    return c;
}

//矩阵快速幂
Mat operator^(Mat a, long long int k)
{
    Mat c;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            c.mat[i][j] = (i==j);
        }
    }
    for(; k; k>>=1)
    {
        if(k&1)
            c = c*a;
        a = a*a;
    }
    return c;
}

int main()
{

    long long int n;
    while(scanf("%lld", &n) && (n!= -1))
    {
        Mat num;
        num.mat[0][0] = 1;
        num.mat[1][0] = 1;
        num.mat[0][1] = 1;
        num.mat[1][1] = 0;
        Mat ans = num^n;
        //cout << ans.mat[1][0] << endl;
        int fn = ans.mat[0][1]%mod;
        cout << fn << endl;

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值