poj1083

https://vjudge.net/problem/POJ-1083

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

 

这题真的很巧,用

这种数组加一记录的方式有效的避免了如果是几个房间同时搬东西如何来标记的难点,这样就可以在输入时动态更新数组,而且如果[1,4]和[3,7]重合了,那么在数组中体现为:T[1:2]=T[5:7]=1,T[3:4]=2,那么在标记最大值时是2,其实就等价于这两个房间不是同时搬家的

同时,面对面的房间如何处理也是很巧妙的:

如果不这样处理,那么当4号被占用的时候,会误以为3号房间也可以同时作业,那么这样就是错误的

 

代码:

//poj1083
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define MAXN 420

int T[MAXN];//T[i]表示第i个房间的走廊被占用了多少次

int main()
{
    int i,j;
    int N;
    int kase;
    int s,t;
    int ans;

    scanf("%d",&kase);
    while(kase--)
    {
        memset(T,0,sizeof(T));
        scanf("%d",&N);
        for(i=1;i<=N;i++)
        {
            scanf("%d%d",&s,&t);
            if(s>t)
                swap(s,t);
            if(s%2==0)
                s--;
            if(t%2!=0)
                t++;
            for(j=s;j<=t;j++)
                T[j]++;
        }
        ans=0;
        for(i=1;i<=400;i++)
            ans=max(ans,T[i]);
        printf("%d\n",ans*10);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值