UVA 458 The Decoder

UVA 458 The Decoder

题意:根据样例输入输出破译字符串 加密原理。

Sample Input:

1JKJ’pz’{ol’{yhklthyr’vm’{ol’Jvu{yvs’Kh{h’Jvywvyh{pvu5
1PIT’pz’h’{yhklthyr’vm’{ol’Pu{lyuh{pvuhs’I|zpulzz’Thjopul’Jvywvyh{pvu5
1KLJ’pz’{ol’{yhklthyr’vm’{ol’Kpnp{hs’Lx|pwtlu{‘Jvywvyh{pvu5

Sample Output:

*CDC is the trademark of the Control Data Corporation.
*IBM is a trademark of the International Business Machine Corporation.
*DEC is the trademark of the Digital Equipment Corporation.

题解:可以看出 加密过程是 字符按照ASCLL 码 +7 后输出。则解密过程为 按照ASCLL 码 -7 。

// UVA 458  
//The Decoder
// by Yanx
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    char a[10010];
    while(gets(a)!='\0')
    {
        for(int i=0;a[i];i++)
        {
            printf("%c",a[i]-7);
        }
            printf("\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值