Can you solve this equation?
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64d
<span style="font-size:18px;"><strong>Description</strong>
现在,给出等式8* X^4+ 7* X^3+ 2* X^2+ 3 * X +6= Y,请找出他在0和100之间的解(包含0和100)。
现在,请你试试运气。。。。
<strong>Input</strong>
输入的第一行包含一个整数T(1 <= T <=100),表示测试用例的数目。接下来T个数字,每一行都有一个实数Y(abs(Y)<=10^10);
Output
对于每个测试用例,如果有解,你应该输出一个实数(精确到小数点后4位,四舍五入),如果在0到100之间无解,就输出“No solution!”。
<strong>Sample Input
</strong>
2
100
-4
<strong>Sample Output</strong>
1.6152
No solution!
思路:二分 套题目所给公式即可;
<strong>代码如下:</strong>
#include<cstdio>
#include<cmath>
#include<cstring>
#define F 1e-10;
using namespace std;
double judge(double mid)
{
return 8.0*pow(mid,4.0)+7.0*pow(mid,3.0)+2.0*pow(mid,2.0)+3.0*mid+6.0;
}
int main()
{
int t;
double y;
double max=8.0*pow(100.0,4.0)+7.0*pow(100.0,3.0)+2.0*pow(100.0,2.0)+3.0*100.0+6.0;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
if(y<6||y>max)
{
printf("No solution!\n");
}
else
{
int k=100;
double a=0.0,b=100.0;
while(k--)
{
double mid=(a+b)/2.0;
if(judge(mid)<y)
{
a=mid+F;
}
else
{
b=mid+F;
}
}
printf("%.4lf\n",a);
}
}
return 0;
}</span>