HDU2199二分

注意 DecimalFormat,以及real精度判断
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

import java.math.BigDecimal;
import java.text.DecimalFormat;
import java.util.ArrayList;
import java.util.Scanner;

/**
 * Created by 95112 on 10/21/2017.
 */
public class CanYouSolveThisEquation {
    public static void main(String[] args){
        Scanner scanner = new Scanner(System.in);
        ArrayList<String>  answers = new ArrayList<>();
        int n = scanner.nextInt();
        for (int i = 0 ; i < n; i++){
            double input = scanner.nextDouble();
            if (input < 6 || input > deal(100))
            {
                answers.add("No solution!");
                continue;
            }
            double x = 0;
            double y = 100;
            double mid = 0;
            while ( y - x > 1e-10){
                mid  = (y + x) / 2;
                double tmp = deal(mid);
                double dValue = tmp - input;
                if (dValue < 0)
                {
                    x = mid + 1e-11;
                    continue;
                }
                else {
                    y = mid - 1e-11;
                    continue;
                }
            }
            BigDecimal bg = new BigDecimal(mid).setScale(4,BigDecimal.ROUND_HALF_UP);
            DecimalFormat df = new DecimalFormat("0.0000");
            answers.add(df.format(bg));
        }
        for (String output : answers)
            System.out.println(output);
    }
    private static double deal(double x){
        return  8 * Math.pow(x,4) + 7 * Math.pow(x,3) + 2 * Math.pow(x,2) + 3 * x + 6;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值