Can you solve this equation?(二分)

B - Can you solve this equation?
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input

    
    
2 100 -4
 

Sample Output

  
  
1.6152 No solution!

AC代码

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while( t-- )
    {
        double y, yy, low = -1, high = 101, midx;            //醉翁之意不在酒
        scanf("%lf", &y);
        while( high-low>1e-9 )
        {
            midx = (high+low)/2.0;
            yy = 8*midx*midx*midx*midx + 7*midx*midx*midx + 2*midx*midx + 3*midx + 6;
            if( y-yy>0 )
                low = midx;
            else if( yy-y>0 )
                high = midx;
        }
        if( midx>=0.0 && midx<=100.0 )
            printf("%.4lf\n", midx);
        else
            printf("No solution!\n");

    }
    return 0;
}

虽然问了小伙伴才AC的,但是真是学到了一点东西,开心


另一个是看了人家的代码之后AC的代码,就是判断输出的方式不同,也是不同的思想

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

double equa( double x )
{
    return  8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}

int main()
{
    int t;
    scanf("%d", &t);
    while( t-- )
    {
        int flag = 0;
        double y, yy, low = 0, high = 100, midx;
        scanf("%lf", &y);
        double M = equa(100.0);
        double m = equa(0.0);
        if( y<m || y>M )            //醉翁之意不在酒
            {
                printf("No solution!\n");
                flag = 1;
                continue;
            }
        while( high-low>1e-9 )
        {
            midx = (high+low)/2.0;
            yy = equa(midx);
            if( y-yy>1e-9 )
                low = midx+1e-9;
            else if( yy-y>1e-9 )
                high = midx-1e-9;
        }
        if( !flag )
            printf("%.4lf\n", midx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值