HDU 5773 The All-purpose Zero

The All-purpose Zero
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.

Input

The first line contains an interger T,denoting the number of the test cases.(T <= 10) 
For each case,the first line contains an interger n,which is the length of the array s. 
The next line contains n intergers separated by a single space, denote each number in S. 

Output

For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.

Sample Input

2
7
2 0 2 1 2 0 5
6
1 2 3 3 0 0

Sample Output

Case #1: 5
Case #2: 5


        
  

Hint

     
     
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[100010],g[100010];
int main()
{
	int t,n,len,cnt;
	int k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		len=cnt=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&g[i]);
			if(g[i]==0)
			cnt++;
			else
			{
				g[i]-=cnt;
				int pos=lower_bound(dp,dp+len,g[i])-dp;
				if(pos==len)
				dp[len++]=g[i];
				else
				dp[pos]=g[i];
			}
		}
		printf("Case #%d: %d\n",k++,len+cnt);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值