hdu 5773 (The All-purpose Zero)

The All-purpose Zero

 

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 题意:求最长上升子序列,0可以变成任意数。
题解:LIS变形,一直没想到怎么处理中间的0,其实可以先去掉0,求出上升子序列,然后加上0的个数lower_bound(s,t,val),返回第一个大于等于val的数的位置,upper_bound(s,t,val)返回第一个大于val的数的位置,两者相减可以得到序列中k的个数。
#include<cstdio>
#include<algorithm>
#define INF 0x3f3f3f3f
#define M 100100
using namespace std;
	int s[M];
	int dp[M];
int main(){
	int t,n,i,sum,ans;
	int cas=1;
	scanf ("%d",&t);
	while (t--){
		sum=0;
		ans=0;
		scanf ("%d",&n);
		for (i=0;i<n;i++){
			scanf ("%d",&s[i]);
			
		}
		fill(dp,dp+n,INF);
		for (i=0;i<n;i++){
			if (s[i]==0){
				ans++;
			}
			else
			*lower_bound(dp,dp+n,s[i]-ans)=s[i]-ans;//去除0
		}
		sum=lower_bound(dp,dp+n,INF)-dp;
		sort (s,s+n);
		sum+=upper_bound(s,s+n,0)-lower_bound(s,s+n,0);//可以直接sum+=ans;
		printf ("Case #%d: %d\n",cas++,sum);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值