杭电5112

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 647    Accepted Submission(s): 337


Problem Description
There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input
  
  
2 3 2 2 1 1 3 4 3 0 3 1 5 2 0
 

Sample Output
  
  
Case #1: 2.00 Case #2: 5.00
Hint
In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.
 

Source
 
大意:输入相应时间对应的位置,求最大的速度。
#include <iostream>
#include <math.h>
#include <stdio.h>
#include<algorithm>
using namespace std;

struct path
{
	int p;//时间
	int s;//位置
}x[10000];

bool cmp(path x,path y)
{
	if(x.p>y.p) return false;//判断,排序
	else return true;
}

int main()
{
	int t,n,i,j=0;
	double sum,max;//储存每次的值,及最大值保存
	cin>>t;
	while (t--)
	{
		j++;
		cin>>n;
		max=0;
		for(i=0;i<n;i++) cin>>x[i].p>>x[i].s;
		sort(x,x+n,cmp);
		for(i=1;i<n;i++)
		{
			sum=abs(x[i].s - x[i-1].s) * 1.0 / (x[i].p - x[i-1].p);//求出速度
			if(sum>max) max=sum;
		}
		printf("Case #%d: %.2lf\n", j, max);//注意输出格式
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值