uva 993 - Product of digits


Product of digits

For a given non-negative integer number N , find the minimal natural Q such that the product of all digits of Q is equal N .

Input

The first line of input contains one positive integer number, which is the number of data sets. Each subsequent line contains one data set which consists of one non-negative integer number N (0$ \le$N$ \le$109) .

Output

For each data set, write one line containing the corresponding natural number Q or `-1' if Q does not exist.

Sample Input

3 
1 
10 
123456789

Sample Output

1 
25 
-1

#include <stdio.h>
#include <math.h>
int main()
{ 
 int i,n,sum,m,t,a[10000];
 scanf("%d",&t);
 while (t--)
 {
  scanf("%d",&n);
  if (n==1) printf("1");
  else
  {
  sum=0; m=9;
  while (m>1)
  {
   if (n%m==0) {a[++sum]=m; n=n/m;}
	       else --m;
  }
  if (n!=1) printf("-1");
  else  for (i=sum;i>=1;i--) printf("%d",a[i]); 
  }
  printf("\n");
 }
 return 0;
}


简单按位贪心

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值